Henderson Collegiate System Status - NCTest is Down – Incident details
All systems operational
NCTest is Down
Resolved
Major outage
Started about 1 month agoLasted about 2 hours
Affected
Network
Major outage from 1:42 PM to 3:46 PM
Internet
Major outage from 1:42 PM to 3:46 PM
Updates
Resolved
Resolved
This incident has been resolved.
Identified
Identified
We have received reports from the state that NCTest is down statewide.
There are no further actions from our side. We are on standby for updates from NCDPI.
Further communication will come from leadership and testing administrators.