Henderson Collegiate - MS Copier Left - Jamming – Incident details

MS Copier Left experiencing degraded performance

MS Copier Left - Jamming

Identified
Degraded performance
Started 2 days ago

Affected

Copiers / Printers

Operational from 4:42 PM to 4:42 PM, Degraded performance from 4:42 PM to 12:00 AM

MS Copier Left

Operational from 4:42 PM to 4:42 PM, Degraded performance from 4:42 PM to 12:00 AM

Updates
  • Identified
    Identified

    A service call has been place for this device. Waiting on a Xerox rep to service.

  • Investigating
    Investigating

    The Help Desk has received report(s) of the copier jamming and is investigating the source of the issue.

    No more tickets are required for issues related to jamming at this time.